Sui Testnet Block Production Halted

Incident Report for ZAN

Resolved

This incident has been resolved.
Posted Jun 29, 2025 - 22:00 UTC

Identified

We are currently experiencing an issue with the Sui Testnet, where block production has halted across the network. Our team is actively collaborating with the Sui Foundation to diagnose and resolve the problem.
Posted Jun 27, 2025 - 22:00 UTC
This incident affected: Sui (Testnet).